Posted By: Ray Vega
Coming from a C# background the naming convention for variables and method names are usually either camelCase or PascalCase:
// C# example string thisIsMyVariable = "a" public void ThisIsMyMethod()
In Python, I have seen the above but I have also seen underscores being used:
# python example this_is_my_variable = 'a' def this_is_my_function():
Is there a more preferable, definitive coding style for Python?
See Python PEP 8: Function and Variable Names:
Function names should be lowercase, with words separated by underscores as necessary to improve readability.
Variable names follow the same convention as function names.